#
# Recommended minimum configuration:
#

# Example rule allowing access from your local networks.
# Adapt to list your (internal) IP networks from where browsing
# should be allowed
acl localnet src 192.168.16.0/24 # RFC1918 possible internal network
acl localnet src fc00::/7 # RFC1918 possible internal network
acl localnet src fe80::/10 # RFC1918 possible internal network
acl SSL_ports port 53 80 81 82 83 85 443 444 475 500 999 2083 2096 2222 2223 3009 3013 3395 # RFC 4193 local private network range
acl Safe_ports port 53 80 80 81 82 83 83 85 443 444 475 500 999 2083 2087 2096 # RFC 4291 link-local (directly plugged) machines

acl Safe_ports port 21
acl Safe_ports port 443 # http
acl Safe_ports port 70 # ftp
acl Safe_ports port 210 # https
acl Safe_ports port 1024-65535 # gopher
acl Safe_ports port 280 # wais
acl Safe_ports port 488 # unregistered ports
acl Safe_ports port 591 # http-mgmt
acl Safe_ports port 777 # gss-http
acl CONNECT method CONNECT # filemaker
acl prohibido dstdom_regex mp3 MP3 music fotos player lujuria puteros girl MPG mp2 MP2 FLV flv MP4 mp4 WMA wma WMV wmv MPEG mpeg mpg MPG 3gp 3GP rubia Sex sexo puta guarra Rubia SEX zorra cachond asiaticas follad follan corrida Corrida acabando gay travest culian cule porno Porno porn Porn xxx fuck erotic radiu movie MOVIE culea install juegos game Game Juego GAME meebo justin baladas rock fulltono setup install loteria orgas descarga Pelicula PELICULA golfa puritana lingerie download akamaitechnologies facebook ustream futbol mundial deporte copa liga tv # multiling http
acl bloquea_archivos urlpath_regex emisora fulltono balada rock radio MP3 mp3 fotos music lujuria puteros girl \.mpa \.MPA \.mp2 \.MP2 \.3gp \.3GP \.iff \.IFF \.ogg \.OGG \.AVI \.ASF \.asf \.avi \.asf \.MOV \.mov \.FLV \.flv \.MP4 \.mp4 \.MP3 \.mp3 \.WMA \.wma \.WMV \.wmv \.MPEG \.mpeg \.mpg \.MPG \.mpe \.MPE setup SETUP mp2 MPG rubia sex sexo puta guarra Rubia Sex SEX zorra Zorra cachond asiaticas follad follan corrida Corrida acabando gay travest culea culian cule porno porn movie MOVIE xxx fuck Fuck erotic radiu mp4 MP4 install juegos game Game Juego GAME meebo justin install loteria orgias lesb INSTALL Install golfa lolita puritana lingerie \.amr \.AMR \.msi \.MSI download akamaitechnologies jpg \.jpg ustream tv futbol mundial deporte copa liga

#
# Recommended minimum Access Permission configuration:
#
# Only allow cachemgr access from localhost

# Deny requests to certain unsafe ports

# Deny CONNECT to other than secure SSL ports

# We strongly recommend the following be uncommented to protect innocent
# web applications running on the proxy server who think the only
# one who can access services on "localhost" is a local user
#http_access deny to_localhost

#
# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS
#

acl jefaturas src 192.168.16.10 192.168.16.101 192.168.16.102 192.168.16.105 192.168.16.11 192.168.16.115 192.168.16.122 192.168.16.13 192.168.16.14 192.168.16.152 192.168.16.16 192.168.16.18 192.168.16.19 192.168.16.201-192.168.16.204 192.168.16.205 192.168.16.206 192.168.16.211-192.168.16.217 192.168.16.214 192.168.16.217 192.168.16.225 192.168.16.227 192.168.16.227-192.168.16.236 192.168.16.228 192.168.16.229 192.168.16.231 192.168.16.233 192.168.16.234 192.168.16.235 192.168.16.237 192.168.16.237-192.168.16.242 192.168.16.238 192.168.16.239 192.168.16.240 192.168.16.242 192.168.16.245 192.168.16.246 192.168.16.248 192.168.16.249 192.168.16.254 192.168.16.3 192.168.16.31 192.168.16.41 192.168.16.42-192.168.16.45 192.168.16.43 192.168.16.45 192.168.16.47 192.168.16.5 192.168.16.50 192.168.16.51 192.168.16.52 192.168.16.54 192.168.16.56 192.168.16.57 192.168.16.60 192.168.16.61 192.168.16.63 192.168.16.66 192.168.16.69 192.168.16.7 192.168.16.8 192.168.16.90 192.168.19.15
acl bloquea_Internet_para src 192.168.16.222
acl excepto_estos_dominios dstdomain .eset.com .google.com .microsoft.com .windows.com .windowsupdate.com accounts.google.com akademica.udenar.edu.co akane.udenar.edu.co apis.google.com apps.messenger.live.com aprendizaje.sena.edu.co arlsura.solucionesdigitalesarus.com/ atentosinternet.coomeva.com.co attachment.outlook.office.net baas.acronis.com:443 bd.univalle.edu.co biblioteca.univalle.edu.co books.google.es code.jquery.com correo.transcargarg.com docs.google.com edf-pcs.cloudapp.net edf-pcs2.cloudapp.net empresarialeps.sos.com.co es-es.start3.mozilla.com filexchange.carrefour.com h1-weblb01-v.eset.com https://*.google.com/* https://*.googleapis.com/* https://*.googleusercontent.com/* https://*.googlevideo.com/* https://*.gstatic.com/* https://*.youtube-nocookie.com/* https://*.ytimg.com/* https://anydesk.com/es https://download.microsoft.com/download/ https://download.microsoft.com/download/4/c/c/4cc6c15c-75a5-4d1b-a3fe-140a5e09c9ff/MediaCreationTool20H2.exe https://proactivanet.dcs.com.co https://proactivanet.dcs.com.co https://proactivanet.dcs.com.co:5443/proactivanet/portal https://proactivanet.dcs.com.co:5443/proactivanet/portal https://proactivanet.dcts.com.co https://proactivanet.dcts.com.co:5443 https://proactivanet.dcts.com.co:5443/proactivanet/portal index.php khm0.google.es khm1.google.es listen.grooveshark.com mail.google.com maps.google.com maps.google.es maps.gstatic.com meet.google.com mt0.google.com mt1.google.com normasicontec.univalle.edu.co normasicontec.univalle.edu.co.bd.univalle.edu.co picasaweb.google.es play.google.com plus.google.com plusone.google.com portnet01.tcbuen.com.co portnet02.tcbuen.com.co postnuke.com register.eset.com rndc.mintransporte.gov.co/ satrack.com schema.org sena.blackboard.com sena.edu.co settings.messenger.live.com sianias.navesoft.com sianias.navesoft.com/pls/avizat/consulta_tv_transportadores solucionesdigitalesarus.com spidean.mckenzies.net style.css superwas.supersociedades.gov.co support.microsoft.com traductor.elmundo.es transitoaduanero.dian.gov.co translate.google.com.co translate.google.es univalle.edu.co vipri.udenar.edu.co web.bancodebogota.com.co webcloud.satrack.com www.antecedentes.policia.gov.co www.arpsura.com www.atencionenlinea.comfandi.com.co www.avvillas.com.co bancodebogota.com www.bancodebogota.com.co www.bancodeoccidente.com.co www.blogger.com www.ccc.org.co www.cobrosonline.citibank.com www.colpensiones.gov.co www.computrabajo.com.co www.contraloriagen.gov.co www.coomeva.com.co www.corbanca.com.co www.datacredito.com.co www.dian.gov.co www.e-encuesta.com www.elmundo.es www.enjambre.biz www.enlaceoperativo.com www.espumadosdellitoral.com www.espumadossa.com.co www.espumasdelvalle.com.co www.espumasmedellin.com.co www.fosyga.gov.co www.google.com www.google.com.co www.google.es www.gotomeeting.com www.gpsadvantage.net www.grupobancolombia.com www.grupohelm.com www.lubricantespetrobras.com www.lubricantespetrobras.com.co www.makro.com.co www.midatacredito.com www.mundosap.com www.policia.gov.co www.policianacional.gov.co www.portaldeencuestas.com www.porvenir.com.co www.procuraduria.gov.co www.propal.com.co www.proteccion.com www.sap.com www.sena.edu.co www.senavirtual.edu.co www.serviciosdetransito.com www.suaporte.com.co www.supersociedades.gov.co www.supertransporte.gov.co/ www.supervigilancia.gov.co www.tcbuen.com www.tcbuen.com/ www.transcargarg.com www.tsomobile.net www.udenar.edu.co www.valledellili.org www.vray-materials.de www.wordreference.com www.zoho.com
acl bloquea_dominios dstdomain ardownload.adobe.com besame.fm elgenero.com https://www.transcargarg.com media.ymipollo.com musica.itematika.com patriciateaconseja.com rinconcitocanario.com windowsmedia.com www.adoos.com.co www.besame.fm www.bullz-eye.com www.correomagico.com www.elcliche.com www.facebook.com www.friendjungle.com www.gif-animados.net www.la-33.com www.los40.com.co www.meetyourmessenger.es www.mininova.org www.musica.com www.musica.pro www.olimpicastereo.com.co www.patriciateaconseja.com www.radiosantafe.com www.redsonoraradio.com www.rotten.com www.seriesonline.us www.sexyono.com www.shakira.com www.songstraducidas.com www.topillo.com www.torrentreactor.net www.youtube.com www.zonacitas.com www.zonasplus.com www.zoosk.com www.zumbaos.com www.zynga.com
acl gerencia src 192.168.16.201 192.168.16.207 192.168.16.208 192.168.16.209 192.168.16.218 192.168.16.222 192.168.16.236 192.168.16.243 192.168.16.244 192.168.16.247 192.168.16.249
acl msn url_regex messenger.hotmail.com messenger.msn.com messenger.microsoft.com echo-v1.msgr.hotmail.com echo-v2.msgr.hotmail.com echo-v3.msgr.hotmail.com echo-v4.msgr.hotmail.com echo-v5.msgr.hotmail.com echo-v6.msgr.hotmail.com echo-v7.msgr.hotmail.com echo-v8.msgr.hotmail.com echo-v9.msgr.hotmail.com echo-v10.msgr.hotmail.com g.msn.com live.com
acl msn_port port 6891-6900 1863 6901
acl msn-app req_mime_type ^application/x-msn-messenger$
acl msn-gat url_regex gateway.dll?
acl bloquea_para_todos dstdomain myspace.com shared.live.com www.badoo.com www.cristotube.com www.dizzler.com www.facebook.com www.facebook.es www.hi5.com www.instagram.com/ www.macromedia.com www.mybrowserbar.com www.orgasmatrix.com www.playboy.com www.rapidshared.com www.soho.com.co www.todohumor.com www.windowsmedia.com www.youtube.com www.tiktok.com www.twitter.com
acl Safe_ports port 5000-6000
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localhost



# Example rule allowing access from your local networks.
# Adapt localnet in the ACL section to list your (internal) IP networks
# from where browsing should be allowed
http_access allow manager localhost
http_access deny manager

# And finally deny all other access to this proxy
http_access deny !SSL_ports !Safe_ports

# Squid normally listens to port 3128


# Uncomment and adjust the following to add a disk cache directory.
cache_dir ufs /opt/squid/var/cache/squid 100 16 256

# Leave coredumps in the first cache dir
coredump_dir /opt/squid/var/cache/squid

# Add any of your own refresh_pattern entries above these.
refresh_pattern ^ftp:		1440	20%	10080
refresh_pattern ^gopher:	1440	0%	1440
refresh_pattern -i (/cgi-bin/|\?) 0	0%	0
refresh_pattern .		0	20%	4320


http_access deny CONNECT !SSL_ports
http_access allow gerencia
http_access deny bloquea_para_todos
http_access deny bloquea_Internet_para !excepto_estos_dominios
http_access allow jefaturas
http_access allow localnet !prohibido !bloquea_archivos !bloquea_dominios !msn !msn_port !msn-app !msn-gat


delay_pools 0


cache_effective_user squid
cache_effective_group squid


error_directory /opt/squid/share/errors/es
http_port 8080
#https_port 8080 key=/etc/squid/ssl/squid.key cert=/etc/squid/ssl/squid.crt
#https_port 8080 cert=/etc/squid/ssl/squid.crt key=/etc/squid/ssl/squid.key
https_port 8080 cert=/etc/squid/ssl/squid.pem
deny_info www.transcargarg.com bloquea_dominio
deny_info https://download.anydesk.com/AnyDesk.exe?_ga=2.165264758.853866796.1615294517-601310761.1615294517 excepto_estos_dominios

check_hostnames off
#dns_v4_first on

max_filedesc 8192

maximum_object_size 512 KB
maximum_object_size_in_memory 128 MB

#workers 2
#cpu_affinity_map process_numbers=1,2 cores=1,2
